生产线安装composer及php cli配置

composer安装及配置
一、下载:(如果是网络原因多试几次,不行的话试试吧https改成http)
curl -sS https://getcomposer.org/installer | php
二、移动composer.phar移动到环境下让其变成可执行:
mv composer.phar /usr/local/bin/composer
三、验证版本:
composer -V
四、使用国内镜像
composer config -g repo.packagist composer https://packagist.phpcomposer.com
以上是网上多数选择,我使用过程中发现packagist.phpcomposer.com的源更新速度比较慢,laravel 5.7出来了,还没能update到,后来换成packagist.laravel-china.org就马上跟新到了
composer config -g repo.packagist composer https://packagist.laravel-china.org
五、升级composer到最新版命令:
composer self-update -vvv

配置cli
在是有composer的时候,如果出现如下报错,则说明php.ini配置的时候为了安全起见把一些风险大的函数给屏蔽了,但composer需要用到。如果直接在配置文件上把禁用的函数去去掉,这必然对我们的系统造成很严重的安全隐患。
[Symfony\Component\Process\Exception\RuntimeException]
The Process class relies on proc_open, which is not available on your PHP installation.

不过compser执行是使用php-cli的,而web使用的是php-fpm或者php-fastcgi。那么只要通过区分不同的php.ini即可解决安全的问题。php-cli在执行的时候是默认先检查有没有php-cli.ini是否存在,不存在才使用php.ini。我们只要在php-cli的目录下建立独立的php-cli.ini配置文件即可。

原理剖析完,我们说说实操:
1.找到php-cli所在目录:我用php7就安装在/usr/local/php/,对应cli所在的目录是/usr/local/php/bin
2.复制现有的php.ini到cli的所在目录
cp -a /usr/local/php/etc/php.ini /usr/local/php/bin
3.重命名配置文件
mv /usr/local/php/bin/php.ini /usr/local/php/bin/php-cli.ini
4.把composer需要用的proc_open和proc_get_status去掉并且保存

这样就可以既安全又方便的在生产线上运行composer了。enjoy。。。

ps:cli情况下修改完配置是不需要reload配置的

赞 (0)
分享到:更多 ()